Etiqueta «wordpress»

Instalar WordPress sobre Nginx + php7 + MariaDB en Debian 9

# apt update && apt upgrade # apt install mariadb-server php7.0 php7.0-fpm php7.0-mysql nginx wget nano certbot –no-install-recommends # wget -O /var/www/wordpress.tar.gz https://wordpress.org/latest.tar.gz # tar xfvz /var/www/wordpress.tar.gz -C /var/www/ # chown -R www-data:www-data /var/www/wordpress # systemctl stop nginx # certbot certonly –standalone -m correo@loquesea.com –agree-tos -d www.dominio.com Ahora borramos todo lo que contenga /etc/nginx/sites-available/default y …

Hacer funcionar wp-cli para publicar desde la shell

wp-cli viene bien tenerlo instalado para administrar un wordpress desde línea de comandos. Es por eso que me salto la explicación de como montar un wordpress (aquí tienes una) y paso directamente a como se monta wp-cli.   Instalar wp-cli   Instalamos como root algunas dependencias:   # apt-get install curl less   Creamos desde …

WPPS – WordPress Pingback Port Scanner

Que no te engañen. No todo lo que quieres contar tiene que ser en texto plano, es decir, algunas veces quieres que sea en una secuencia de imágenes más difíciles de interpretar por NO-humanos. Esto es un ejemplo de post de esos que prefiero contar con imágenes a sabiendas que el texto posiciona mejor. Esto …

Poedit – La herramienta buena para traducir

Una buena forma de contribuir al software libre es traduciendo aplicaciones. En el mundo de los themes y plug-ins de wordpress es muy normal encontrar un directorio llamado languages en el que encontrar un archivo pot, po o mo (o todos). La herramienta para trabajar con estos archivos más molona y libre es Poedit . …

10 ocurrencias recurrentes con wordpress

1. Subiendo contenido que excede del tamaño permitido y que te de un error tras la subida. 2. Has metido demasiados plugins   3. Cuando subes un gif y no se ve la animación por no estar a tamaño completo. 4. Cuando ves el theme wordpress de un hacker maligno (alto contraste) 5. Lo que …

WPscan en GNU/Linux desde el código

He dejado el proceso en PDF aquí: wp-scan.pdf (las instrucciones para compilar lo necesario y que chute como ha de ser). No obstante pasamos a relatarlo por aquí también. Se trata de una herramienta escrita en ruby que permite comprobar vulnerabilidades en webs que usan wordpress.   Instalación de wpscan en GNU/Linux desde el código Para …