Compilar GCC 7.3 en Debian 9

Es posible ver la versión de gcc así:

gcc --version

Posiblemente si andas usando Debian 9 estés usando la versión de gcc 6.3 y actualmente la versión más reciente de gcc es la 7.3.

Aquí pueden verse los requisitos para compilar gcc: http://gcc.gnu.org/install/prerequisites.html.

Entre los que destaca por ejemplo que para compilar GCC vamos a requerir GMP 4.2 o superior y por tanto es bueno empezar a ir completando las dependencias necesarias:

$ wget https://gmplib.org/download/gmp/gmp-6.1.2.tar.xz
$ tar xfv gmp-6.1.2.tar.xz
$ cd gmp-6.1.2
$ ./configure 
$ make
$ make check
# make install

También MPFR 2.4.0 o superior:

$ wget http://www.mpfr.org/mpfr-current/mpfr-4.0.1.tar.gz
$ tar xfvz mpfr-4.0.1.tar.gz 
$ cd mpfr-4.0.1
$ ./configure 
$ make
$ make install

Y MPC 0.8.0 o superior que puede instalarse desde repositorios:

# apt-get install mpc libmpc-dev

Luego ya se puede bajar GCC por ejemplo así:

$ wget "ftp://ftp.irisa.fr/pub/mirrors/gcc.gnu.org/gcc/releases/gcc-7.3.0/gcc-7.3.0.tar.gz"
$ tar xfvz gcc-7.3.0.tar.gz

Accedemos al directorio y lo compilamos así con gcc:

$ ./configure --disable-multilib
$ make
# make install 
$ gcc --version

próximo Publicación

Atrás Publicación

Dejar una contestacion

© 2018 [ MIERDA TV ]

Tema de Anders Norén